[Resolved] Disruption with RevDriver's Research On Demand

Started on November 5, 2020 at 2:01 AM. Resolved after less than a minute

Affected

RevDriver
  • Resolved
    November 5, 2020 at 2:01 AM

    We have identified an issue with RevDriver's integration with our research ticketing system is down. This has led to a disruption in receiving and subsequently processing your research requests made via RevDriver. We are working to fix this issue and appreciate your patience. In the interim you can submit your request https://support.salesintel.io/hc/en-us/requests/new.