Resolved
Revdriver Sign up and Password Resetting

Started
November 10, 2021 at 3:01 PM
Status
Resolved after less than a minute
Affected
RevDriver

Impact

Operational
  • Resolved
    November 10, 2021 at 3:01 PM

    We are currently investigating this incident. Potential new users are unable to sign up for the Revdriver.