Resolved
RevDriver not loading

Started
June 08, 2021 at 1:57 PM
Status
Resolved after about 23 hours
Affected
RevDriver

Impact

Degraded performance
  • Resolved
    June 09, 2021 at 12:30 PM

    We just resolved the issue!

  • Resolved
    June 08, 2021 at 1:57 PM

    We are currently investigating this incident and will update the status page with progress. Please reach out to support@salesintel.io with any questions.