[Resolved] RevDriver Hidden Contact Information

Started on September 2, 2021 at 1:26 PM. Resolved after 7 days

Affected

RevDriver
  • Investigating
    September 2, 2021 at 1:26 PM

    We are currently investigating this incident. There will be an update in RevDriver that will fix the contact information from being hidden. This should be in place in the next few hours.

  • Resolved
    September 9, 2021 at 5:33 PM

    We just resolved the issue!