Resolved
Slowness across SalesIntel platform and applications

Started
November 28, 2023 at 3:30 PM
Status
Resolved after about 6 hours

Impact

Degraded performance
Affected
Portal/Web Application
RevDriver
Salesforce Managed Package
APIs
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We continue to monitor platform health. Performance has returned to usual.

  • Identified
    Identified

    Application performance has stabilized and we have identified the issue. Our team is continuing to remedy the underlying issue.

  • Investigating
    Investigating

    We are currently investigating increased latency across our platform, leading to slowness (or failures) in logging in, loading application resources, or searching. Our teams are looking into it at high priority. We are scaling up our systems to help mitigate the impact.