Resolved
Slowness across SalesIntel platform and applications

Started
May 25, 2023 at 5:17 PM
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
Portal/Web Application
RevDriver
Salesforce Managed Package
APIs
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Our team has implemented a fix and is monitoring the results.

  • Identified
    Identified

    We have identified the cause of this performance issue and are working on remediation.

  • Investigating
    Investigating

    We are currently investigating increased latency across our platform, leading to slowness (or failures) in loading resources. Our teams are looking into it at high priority.