Resolved
Slowness across SalesIntel platform and applications

Started
May 22, 2023 at 2:20 PM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Portal/Web Application
RevDriver
Salesforce Managed Package
APIs
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience.

  • Monitoring
    Monitoring

    Our team has implemented a fix and is monitoring the results.

  • Identified
    Identified

    We have identified the source of this issue and are working on a resolution.

  • Investigating
    Investigating

    We are currently investigating increased latency across our platform, leading to slowness (or failures) in loading resources. Our teams are looking into it at high priority.