Resolved
Search experience running slowly

Started
April 26, 2023 at 1:13 PM
Status
Resolved after about 3 hours

Impact

Degraded performance
Affected
Portal/Web Application
RevDriver
Salesforce Managed Package
APIs
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience.

  • Monitoring
    Monitoring

    We are monitoring a fix to product latency and are seeing improvements.

  • Investigating
    Investigating

    Our search experience in all products is currently running slowly and users may experience timeouts/infinite loading states. There may be some difficulty loading the SalesIntel web app or Chrome extension, but this is infrequent. Our engineers are reviewing.