SalesIntel - Increased latency due to AWS outages – Incident details

Increased latency due to AWS outages

Resolved
Degraded performance
Started 3 days agoLasted about 8 hours

Affected

Portal/Web Application

Degraded performance from 12:30 PM to 7:44 PM, Operational from 7:44 PM to 8:52 PM

RevDriver

Degraded performance from 12:30 PM to 7:44 PM, Operational from 7:44 PM to 8:52 PM

Salesforce Managed Package

Degraded performance from 12:30 PM to 7:44 PM, Operational from 7:44 PM to 8:52 PM

APIs

Degraded performance from 12:30 PM to 7:44 PM, Operational from 7:44 PM to 8:52 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    The fixes put in place by AWS have been successful so far and SalesIntel platform services have recovered. We are continuing to monitor the situation to optimize performance, as well as to rerun any jobs that were not executed as a result of AWS outages.

  • Update
    Update

    AWS has announced mitigations being put in place that should directly improve the SalesIntel platform health. We are watching the progression of this approach. At this time, the platform is still experiencing the same degradation.

  • Identified
    Identified

    We have identified that this issue is rooted in the inability to scale instances to support normal usage patterns, due to ongoing AWS issues. It is further impacted by newly-discovered AWS connectivity issues. We continue to monitor AWS updates. In general, requests may be very slow to process or may fail.

  • Investigating
    Investigating

    Due to AWS outages, we are experiencing latency throughout the SalesIntel platform starting from 8.30ET. We are monitoring the AWS status and remediating where possible.