Resolved
Increased latency in SalesIntel products

Started
March 10, 2022 at 4:40 PM
Status
Resolved after about 10 hours

Impact

Degraded performance
Affected
Portal
RevDriver
Salesforce Managed Package
  • Resolved
    March 11, 2022 at 2:30 AM

    Our team has applied a series of fixes to solve latency issues experienced today. We will monitor the situation ongoing and continue to improve where possible.

  • Identified
    March 10, 2022 at 7:00 PM

    We have identified a solution to decrease some of the latency our users are experiencing and are implementing a fix. At the current time, users should be able to log in and complete tasks, but may find intermittent slowness. We will provide another update once the solution is in place.

  • Investigating
    March 10, 2022 at 4:40 PM

    We are currently investigating increased latency in the SalesIntel products. Users may experience difficulty logging in, using the prospect/company search features, and completing other tasks. We will provide updates as available.